股票之声

 找回密码
 注册
查看: 14751|回复: 4

[大智慧L2] MACD强化指标

[复制链接]
发表于 2009-12-25 11:22 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x
SQX:=(C-MA(CLOSE,13))*100;
DIFF:EMA(MA(SQX,7),1),COLORWHITE;
DEA:EMA(DIFF,7),COLORYELLOW;
MACDDIFF-DEA)*2,COLORSTICK;
PARTLINE(15,CROSS(DIFF,DEA) AND DIFF<-0.1),COLORYELLOW,LINETHICK4,CROSSDOT;
低位金叉:IF(CROSS(DIFF,DEA) AND DIFF<-0.1,15,0),COLORYELLOW,LINETHICK0;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
PARTLINE(28,CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1),COLORFF00FF,LINETHICK4,CROSSDOT;
二次金叉:IF(CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,28,0),COLORFF00FF,LINETHICK0;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
PARTLINE(40,REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA)),COLORRED,LINETHICK4,CROSSDOT;
底背离:IF(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),40,0),COLORRED,LINETHICK0;
势: DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORGREEN;{,COLORRED;}
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
PARTLINE(66,REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF)),COLORF08000,LINETHICK4,CROSSDOT;
顶背离_:IF(REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),66,0),COLORF08000,LINETHICK0;
压: DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORFFBB99;
A3:=CROSS(DIFF,DEA) AND DEA<0;
PARTLINE(53,FILTER(COUNT(A3,21)=2,10)),COLORWHITE,LINETHICK4,CROSSDOT;
零下二次金叉_:IF(FILTER(COUNT(A3,21)=2,10),53,0),COLORWHITE,LINETHICK0;
DRAWICON(CROSS(DIFF,DEA) ,DIFF,7),LAYER0,ALIGN1;
DRAWICON(CROSS(DEA,DIFF) , DEA,8),LAYER0,ALIGN1;
金叉:if(CROSS(DIFF,DEA),diff,0),color00ff00,stick,linethick1;
死叉:if(CROSS(DEA,DIFF),diff,0),colorff0099,stick,linethick1;
发表于 2009-12-25 12:16 | 显示全部楼层
谢朗少....................
发表于 2010-4-10 10:31 | 显示全部楼层
谢朗少....................
发表于 2019-4-26 19:44 | 显示全部楼层
感谢分享,学习~~
回复 支持 反对

使用道具 举报

发表于 2020-2-15 21:08 | 显示全部楼层

感谢分享,学习~~
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

Archiver|手机版|小黑屋|股票之声 ( 京ICP证080305号 )

GMT+8, 2021-9-24 10:06 , Processed in 0.040115 second(s), 5 queries , MemCache On.

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表