股票之声

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 55239|回复: 191

[通达信] 不为哗众取宠,发一个准确率很高的主图指标(无未来)

[复制链接]
发表于 2011-12-5 10:35 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x
不回复源码不全
指标只是参考,理念才重要,是人驾驭指标,不是指标驾驭人。

源码如下:具体怎么用,自己去体会。
EMA13:EMA(C,13),COLORWHITE;
EMA21:EMA(C,21),COLORYELLOW;
EMA34:EMA(C,34),COLORFF00FF;
EMA60:MA(C,60),COLORFFCC66;
VAR2:=(2*CLOSE+HIGH+LOW)/4;
VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4:=LLV(LOW,5);
VAR5:=HHV(HIGH,4);
散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3;
DRAWTEXT(CROSS(散户,庄家) AND 散户<50 AND 29<散户,L-0.05,'短进'),COLORMAGENTA;
DRAWTEXT(CROSS(庄家,散户) AND 散户>40 AND 71>散户,H+0.05,'短出'),COLORGREEN;
DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'低吸'),COLORWHITE;
DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.05,'高减'),COLORYELLOW;
DRAWICON(CROSS(散户,庄家) AND 散户<30,L-0.05,1);
DRAWICON(CROSS(庄家,散户) AND 散户>70,H+0.05,2);
VAR9:=CLOSE-REF(CLOSE,5);
VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5);
VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20);
卖出:=IF(VARA>0 AND CROSS(VARC,VARA),90,100);
DRAWTEXT(VARA>0 AND CROSS(VARC,VARA),H+0.05,'中线逃!'),COLORYELLOW;
DRAWICON(卖出<0,H+0.05,2);
买线:=EMA(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);   
B1:IF(CROSS(买线,卖线),L-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORMAGENTA;
S1:IF(CROSS(80,RSI)*30,H+0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
S2:IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.02,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORGREEN;


发表于 2015-8-12 18:06 | 显示全部楼层
谢谢,试试看
回复 支持 1 反对 0

使用道具 举报

发表于 2011-12-5 12:03 | 显示全部楼层
thank you very much.
发表于 2011-12-5 14:50 | 显示全部楼层
很不错的指标 可以试试!
发表于 2011-12-6 22:23 | 显示全部楼层
{:soso_e120:}老大都说不错一定好
发表于 2011-12-6 22:39 | 显示全部楼层
;P;P顶顶顶!请教用法?
发表于 2011-12-7 01:32 | 显示全部楼层
thank you very much.
发表于 2011-12-19 23:14 | 显示全部楼层
kkkkkkkkkkkkkkkk
发表于 2012-1-15 13:04 | 显示全部楼层
{:soso_e179:}{:soso_e179:}{:soso_e179:}3Q
发表于 2012-1-19 21:41 | 显示全部楼层
非常感谢 OKOKOKOKOK
发表于 2012-2-3 16:53 | 显示全部楼层
123非常感谢 OKOKOKOKOK
发表于 2012-2-11 11:19 | 显示全部楼层
非常感谢 OKOKOKOKOK
发表于 2012-2-22 12:35 | 显示全部楼层
xinkule{:soso_e179:}
发表于 2012-2-26 21:14 | 显示全部楼层
我怎么看不到指标?
发表于 2012-3-11 23:38 | 显示全部楼层
不知道怎么样,试试吧。先谢过了。
发表于 2012-3-12 09:42 | 显示全部楼层
{:soso_e179:}
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|Archiver|手机版|股票之声 ( 京ICP证080305号 )

GMT+8, 2018-11-17 11:37 , Processed in 0.023995 second(s), 13 queries , APC On.

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.
【联系我们】 QQ:76010941 / 180083319 固话:010-6818 4181 邮箱:tianyifund@sina.com

快速回复 返回顶部 返回列表