股票之声

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 22921|回复: 12

[通达信] 指标:买入大涨 优化 !

[复制链接]
发表于 2010-4-10 19:19 | 显示全部楼层 |阅读模式
发表于 2010-4-10 22:46 | 显示全部楼层

A:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));
B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:IF(MA(CLOSE,17)<B,B,MA(CLOSE,17)),COLORFF00FF,LINETHICK2;
操作线:分水岭-(EMA(C,3)-分水岭),COLOR00FFFF,LINETHICK2;
PM:MA(C,5),COLORWHITE,LINETHICK2;
IF(PM> REF(PM,1),PM,DRAWNULL),COLORRED,LINETHICK2;
IF(PM=REF(PM,1),PM,DRAWNULL),COLORRED;
IF(PM<REF(PM,1),PM,DRAWNULL),COLORFF9900,LINETHICK2;
S:=(PM> 操作线);
DD:=分水岭<REF(分水岭,1);
IF(DD,分水岭,DRAWNULL),COLOR00FF00,LINETHICK2;
IF(S,分水岭,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK4;
DRAWICON(CROSS(分水岭,操作线),分水岭-0.1,1);{买入红箭头}
A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));
B1:=REF(C,A1+1)> C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA");
DRAWTEXT(B1> 0,L-0.02,'MACD底背离'),COLOR00FFFF;{MACD底背离}
A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));
B2:=REF(C,A2+1)> C AND REF("KDJ.K",A2+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");
DRAWTEXT(B2,L-0.10,'KDJ底背离'),COLORFF00FF;{KDJ底背离}
A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
B3:=REF(C,A3+1)> C AND REF("RSI.RSI1",A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2");
DRAWTEXT(B3> 0,L-0.18,'RSI底背离'),COLOR0000FF;{RSI底背离}
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)> "MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF");
DRAWTEXT(D1> 0,H+0.16,'MACD顶背离'),COLOR00FF00;{MACD顶背离}
C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K",C2+1)> "KDJ.K" AND CROSS("KDJ.D","KDJ.K");
DRAWTEXT(D2> 0,H+0.08,'KDJ顶背离'),COLORFFFFCC;{KDJ顶背离}
C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1",C3+1)> "RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");
DRAWTEXT(D3> 0,H+0.04,'RSI顶背离'),COLORFF9900;{RSI顶背

回复 支持 1 反对 0

使用道具 举报

发表于 2010-4-12 01:27 | 显示全部楼层
当前公式 : 买入大涨 (指标画线公式) 
错误句 :
DRAWTEXT(买入,35,14),COLOR00909
详细信息 : 未知字符串 COLOR00909
错误起始位置 : 905 ; 长度: 10
发表于 2015-4-9 23:52 | 显示全部楼层
类             BOLL
发表于 2015-6-1 17:30 | 显示全部楼层
周建国 发表于 2010-4-10 22:46
A:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1)); B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17) ...

看看,谢谢分享
发表于 2015-6-5 08:29 | 显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽
发表于 2015-7-24 12:52 | 显示全部楼层
很好的技术指标
发表于 2015-10-17 19:38 | 显示全部楼层
11111111111111
发表于 2015-10-17 20:14 | 显示全部楼层
当前公式 : 买入大涨 (指标画线公式)  
错误句 :  B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17) ;
B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1)
详细信息 : 变量 B 定义重复!
错误起始位置 : 16 ; 长度: 3
发表于 2015-10-17 20:16 | 显示全部楼层
通过了,谢谢

发表于 2016-3-3 13:01 | 显示全部楼层
huifu  you yong jiu ding
发表于 2016-3-3 13:01 | 显示全部楼层
huifu  you yong jiu ding
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|Archiver|手机版|股票之声 ( 京ICP证080305号 )

GMT+8, 2018-11-17 11:39 , Processed in 0.027785 second(s), 11 queries , APC On.

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.
【联系我们】 QQ:76010941 / 180083319 固话:010-6818 4181 邮箱:tianyifund@sina.com

快速回复 返回顶部 返回列表